Issues with Dibs
Incident Report for Norce [Jetshop]
Resolved
This issue has now been resolved.
Posted Apr 24, 2018 - 10:31 CEST
Investigating
We're experiencing problems with card payment through Dibs. Customers may receive an error on the confirmation page but the order goes through. We are investigating together with Dibs.
Posted Apr 23, 2018 - 17:12 CEST