Access issues
Incident Report for Norce [Jetshop]
Resolved
Telia had network issues, those have now been resolved.
Posted Feb 23, 2021 - 15:31 CET
Investigating
Some shops may have access problems, we are investigating this issue right now.
Posted Feb 23, 2021 - 14:43 CET
This incident affected: Norce [Jetshop] Commerce and Norce [Jetshop] Storefront.