Issue in hosting environment
Incident Report for Norce [Jetshop]
Resolved
Between 06:17 and 07:10 we experienced and issue that led to the Administration not working properly. This has been resolved and we are looking into exactly why this occured and making sure it does not reoccur.
Posted Feb 06, 2020 - 06:00 CET